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Getting Started with PDI and Hadoop

Pentaho provides a complete big data analytics solution that supports the entire big data analytics process.
From big data aggregation, preparation, and integration, to interactive visualization, analysis, and prediction,
Pentaho allows you to harvest the meaningful patterns buried in big data stores. Analyzing your big data sets
gives you the ability to identify new revenue sources, develop loyal and profitable customer relationships, and

run your organization more efficiently and cost effectively.

+ Pentaho, Big Data, and Hadoop
+ About Hadoop
+ Big Data Resources
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Pentaho, Big Data, and Hadoop

The term big data applies to very large, complex, or dynamic datasets that need to be stored and managed
over a long time. To derive benefits from big data, you need the ability to access, process, and analyze data as
it is being created. However, the size and structure of big data makes it very inefficient to maintain and process

it using traditional relational databases.

Big data solutions re-engineer the components of traditional databases—data storage, retrieval, query,
processing—and massively scales them.

Pentaho Big Data Overview

Pentaho increases speed-of-thought analysis against even the largest of big data stores by focusing on the
features that deliver performance.

* Instant access—Pentaho provides visual tools to make it easy to define the sets of data that are
important to you for interactive analysis. These data sets and associated analytics can be easily shared
with others, and as new business questions arise, new views of data can be defined for interactive

analysis.

* High performance platform—Pentaho is built on a modern, lightweight, high performance platform. This
platform fully leverages 64-bit, multi-core processors and large memory spaces to efficiently leverage the

power of contemporary hardware.

* Extreme-scale, in-memory caching—Pentaho is unique in leveraging external data grid technologies,
such as Infinispan and Memcached to load vast amounts of data into memory so that it is instantly
available for speed-of-thought analysis.

* Federated data integration—Data can be extracted from multiple sources, including big data and
traditional data stores, integrated together and then flowed directly into reports, without needing an

enterprise data warehouse or data mart.
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About Hadoop

The Apache Hadoop software library is a framework that allows for the distributed processing of large data
sets across clusters of computers using simple programming models. It is designed to scale up from single
servers to thousands of machines, each offering local computation and storage. Rather than rely on hardware
to deliver high-availability, the library itself is designed to detect and handle failures at the application layer, so

delivering a highly-available service on top of a cluster of computers, each of which may be prone to failures.

A Hadoop platform consists of a Hadoop kernel, a MapReduce model, a distributed file system, and often a
number of related projects—such as Apache Hive, Apache HBase, and others.

A Hadoop Distributed File System, commonly referred to as HDFS, is a Java-based, distributed, scalable, and

portable file system for the Hadoop framework.
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Big Data Resources

+ Pentaho Big Data Analytics Center
+ Pentaho Big Data Wiki

= Apache Hadoop project -- A project that contains libraries that allows for the distributed processing of large data
sets across clusters of computers using simple programming models. There are several modules, including the
Hadoop Distributed File System (HDFS), which is a distributed file system that provides high-throughput access to
application data and Hadoop MapReduce, which is a key algorithm to distribute work around a cluster.

» Avro—A data serialization system

* Cassandra—A scalable multi-master database with no single points of failure

* HBase—A scalable, distributed database that supports structured data storage for large tables

* Hive—A data warehouse infrastructure that provides data summarization and on-demand querying
* Pig—A high-level, data-flow language and execution framework for parallel computation

* ZooKeeper—A high-performance coordination service for distributed applications

* MongoDB— A NoSQL open source document-oriented database system developed and supported
by 10gen

* Splunk - A data collection, visualization and indexing engine for operational intelligence that is developed
by Splunk, Inc.

* CouchDB—A NoSQL open source document-oriented database system developed and supported

by Apache
* Sgoop—Software for transferring data between relational databases and Hadoop

* Oozie—A workflow scheduler system to manage Hadoop jobs
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Configure Your Big Data Environment

Configuring a Pentaho component such as Spoon, DI Server, BA Server, PRD, Metadata Editor is easy. Pentaho
supports many different Hadoop distributions including Cloudera, MapR, Hortonworks, DataStax, and Apache.

To configure the Pentaho, do two things.

= Get the Hadoop distribution you want to use
» Set the active Hadoop distribution

For instructions on how to do these things, and to see which Hadoop Distributions we support, see Configure

Pentaho for Your Hadoop Distribution and Version on the Pentaho Big Data Wiki.
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Working with Big Data and Hadoop in PDI

Pentaho Data Integration (PDI) can operate in two distinct modes, job orchestration and data transformation.

Within PDI they are referred to as jobs and transformations.

PDI jobs sequence a set of entries that encapsulate actions. An example of a PDI big data job would be to check
for existence of new log files, copy the new files to HDFS, execute a MapReduce task to aggregate the weblog

into a click stream and stage that clickstream data in an analytic database.

PDI transformations consist of a set of steps that execute in parallel and operate on a stream of data columns.
The columns usually flow from one system, through the PDI engine, where new columns can be calculated or
values can be looked up and added to the stream. The data stream is then sent to a receiving system like a

Hadoop cluster, a database, or even the Pentaho Reporting Engine.

The tutorials within this section illustrate how to use PDI jobs and transforms in typical big data scenarios. PDI
job entries and transformation steps are described in the Transformation Step Reference and Job Entry
Reference sections of Administer the DI Server.

PDI's Big Data Plugin

The Pentaho Big Data plugin contains all of the job entries and transformation steps required for working with

Hadoop, Cassandra, and MongoDB.

By default, PDl is pre-configured to work with Apache Hadoop 0.20.X. But PDI can be configured to
communicate with most popular Hadoop distributions. Instructions for changing Hadoop configurations are
covered in the Configure Your Big Data Environment section.

For a list of supported big data technology, including which configurations of Hadoop are currently supported,

see the section on Supported Components.

Using PDI Outside and Inside the Hadoop Cluster

PDI is unique in that it can execute both outside of a Hadoop cluster and within the nodes of a hadoop

cluster. From outside a Hadoop cluster, PDI can extract data from or load data into Hadoop HDFS, Hive and
HBase. When executed within the Hadoop cluster, PDI transformations can be used as Mapper and/or Reducer

tasks, allowing PDI with Pentaho MapReduce to be used as visual programming tool for MapReduce.

These videos demonstrate using PDI to work with Hadoop from both inside and outside a Hadoop cluster.

= Loading Data into Hadoop from outside the Hadoop cluster is a 5-minute video that demonstrates moving data
using a PDI job and transformation: http://www.youtube.com/watch?v=Ylekzmd6TAc
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= Use Pentaho MapReduce to interactively design a data flow for a MapReduce job without writing scripts or code.
Here is a 12 minute video that provides an overview of the process: http://www.youtube.com/
watch?v=KZe1UugxXcs.

+ Pentaho MapReduce Workflow

+ PDI Hadoop Job Workflow

+ Hadoop to PDI Data Type Conversion
+ Hadoop Hive-Specific SQL Limitations
+ Big Data Tutorials
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Pentaho MapReduce Workflow

PDI and Pentaho MapReduce enables you to pull data from a Hadoop cluster, transform it, and pass it back to

the cluster. Here is how you would approach doing this.

PDI Transformation

Start by deciding what you want to do with your data, open a PDI transformation, and drag the appropriate
steps onto the canvas, configuring the steps to meet your data requirements. Drag the specifically-designed
Hadoop MapReduce Input and Hadoop MapReduce Output steps onto the canvas. PDI provides these steps
to completely avoid the need to write Java classes for this functionality. Configure both of these steps as
needed. Once you have configured all the steps, add hops to sequence the steps as a transformation. Follow
the workflow as shown in this sample transformation in order to properly communicate with Hadoop. Name

this transformation Mapper.

Hadoop will pass data into this step based on the

format defined in the Hadoop Trans job Executor Define the output of this Transformation as the word we've split
used to run this mapper. For this example we from the row and the count of 1 (it's only 1 word after all).
assume the input will be: These key-value pairs are passed to the reducer where they are

rouped by the output key and tallied up.
(hadoop-generated key, line from text file) grevpecty K o B

Hadoop Input
Split words to rows Add value
In this particular example, each "row® contains
several words which we want to split so they :’ﬂ”;‘:ﬂ:‘:{ "‘:1 "'S"Er';u' have
may be individually counted, A COCNE i :

Hadoop communicates in key/value pairs. PDI uses the MapReduce Input step to define how key/value pairs
from Hadoop are interpreted by PDI. The MapReduce Input dialog box enables you to configure the

MapReduce Input step.
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L MapReduce Input X

Step name |Mapﬁeduce Input |

Type Length Precision
Key field | Number W |D ||D |
walue field | Number ~ ||:| ||I:l |

o[ canee

PDI uses a MapReduce Output step to pass the output back to Hadoop. The MapReduce Output dialog box

enables you to configure the MapReduce Output step.

& MapReduceOutput x

Step name |MapReduce Output|

Key field key w

Walue field | value v

e | cance

What happens in the middle is entirely up to you. Pentaho provides many sample steps you can alter to create

the functionality you need.

PDI Job

Once you have created the Mapper transformation, you are ready to include it in a Pentaho MapReduce job
entry and build a MapReduce job. Open a PDI job and drag the specifically-designed Pentaho MapReduce job
entry onto the canvas. In addition to ordinary transformation work, this entry is designed to execute mapper/
reducer functions within PDI. Again, no need to provide a Java class to achieve this.

Configure the Pentaho MapReduce entry to use the transformation as a mapper. Drag and drop a Start job
entry, other job entries as needed, and result jobentries to handle the output onto the canvas. Add hops to
sequence the entries into a job that you execute in PDI.

The workflow for the job should look something like this.
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M!fr Success
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Copy Files to HDFS  Pentaho MapReduce (Wordcount)
Failure

The Pentaho MapReduce dialog box enables you to configure the Pentaho MapReduce entry.

Pentaho MapReduce

Name: IPentaho MapReduce |
Hadoop Job Name: I ]’
(Mapper™. Combiner| Reducer| Job Setup | Cluster| User Defined|

Look in: | Local v

Mapper Transformation: | PlElrowsa...}

Mapper Input Step Name: | |0

Mapper Qutput Step Name: | |0

[m] [ Cancel ‘
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PDI Hadoop Job Workflow

PDI enables you to execute a Java class from within a PDI/Spoon job to perform operations on Hadoop data.
The way you approach doing this is similar to the way would for any other PDI job. The specifically-designed
job entry that handles the Java class is Hadoop Job Executor. In this illustration it is used in the WordCount -

Advanced entry.

Cleans up the output direc
START

=0

Hadoop WordCount Map Reduce Job
-Edit the HDFS hostname

Clean Dutput 0 -Edit the Job Tracker hostname

m
WordCount - Advanced \'-*\
J Monitor the logs for progress
(f biccking option ks selected)

Success

The Hadoop Job Executor dialog box enables you to configure the entry with a jar file that contains the Java

class.
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Hadoop Job Executor X

MName: IWDrdCuunt - Simple I

Hadoop Job Name: |PDI Hadoop - WordCount - Simple I

Jar: | Jsamples/jobs/hadoop/pentaho-mapreduce-sample jar || Browse... |

Configuration
O Simple ) Advanced

Command line arguments: | /junit/wordcount/input fjunit/wordcount/pdioutput

OK _H Cancel

L9 o

If you are using the Amazon Elastic MapReduce (EMR) service, you can Amazon EMR Job Executor. job entry to
execute the Java class This differs from the standard Hadoop Job Executor in that it contains connection

information for Amazon S3 and configuration options for EMR.
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& Amazon EMR Job Executor X

MName: lP.mazon EMR Job Executor l
]@
]'@
]&

EMR Job Flow Name: [

Existing JobFlow Id (optional): I

AWS Access Key: |

AWS Secret Key: I g

Browse...

|4>
l'@

S3 Staging Directory: |

MapReduce Jar: I Browse...

®

Command Line Arguments

Number of Instances: 4’

Master Instance Type: | Small [m1.small] v

Slave Instance Type: | Small [ml.small] v

Enable Blocking

Logging Interval ¢
\ Cancel
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Hadoop to PDI Data Type Conversion

The Hadoop Job Executor and Pentaho MapReduce steps have an advanced configuration mode that enables
you to specify data types for the job's input and output. PDI is unable to detect foreign data types on its own;
therefore you must specify the input and output data types in the Job Setup tab. This table explains the

relationship between Hadoop data types and their PDI equivalents.

PDI (Kettle) Data Type Apache Hadoop Data Type

java.lang.Integer org.apache.hadoop.io.IntWritable

Jjava.lang.Long org.apache.hadoop.io.IntWritable
java.lang.Long org.apache.hadoop.io.LongWritable
org.apache.hadoop.io.IntWritable java.lang.Long

java.lang.String org.apache.hadoop.io.Text
java.lang.String org.apache.hadoop.io.IntWritable
org.apache.hadoop.io.LongWritable org.apache.hadoop.io.Text

org.apache.hadoop.io.LongWritable java.lang.Long

For more information on configuring Pentaho MapReduce to convert to additional data types, see
http://wiki.pentaho.com/display/BAD/Pentaho+MapReduce.
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Hadoop Hive-Specific SQL Limitations

There are a few key limitations in Hive that prevent some regular Metadata Editor features from working as

intended, and limit the structure of your SQL queries in Report Designer:

= Outer joins are not supported.
= Each column can only be used once in a SELECT clause. Duplicate columns in SELECT statements cause errors.

= Conditional joins can only use the = conditional unless you use a WHERE clause. Any non-equal conditional in a
FROM statement forces the Metadata Editor to use a cartesian join and a WHERE clause conditional to limit it. This
is not much of a limitation, but it may seem unusual to experienced Metadata Editor users who are accustomed to
working with SQL databases.

= INSERT statements have a specific syntax and some limitations. Hive 0.14 supports insert statements with
a specific syntax: INSERT INTO TABLE tablename [PARTITION (partcoll[=valll,
partcol2[=val2] ...)] VALUES values row [, values row ...]. Thereare alsosome limitations
surrounding use of the INSERT statement with the SORTED BY clause, non-support of literals for complex types,
and the insertion of values into columns. For more details see:

= https://cwiki.apache.org/confluence/display/Hive/LanguageManual+DML
» https://cwiki.apache.org/confluence/display/Hive/Hive+Transactions
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Big Data Tutorials

These sections contain guidance and instructions about using Pentaho technology as part of your overall big
data strategy. Each section is a series of scenario-based tutorials that demonstrate the integration between
Pentaho and Hadoop using a sample data set.

+ Hadoop Tutorials

+ MapR Tutorials
« Cassandra Tutorials
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Hadoop Tutorials

These tutorials are organized by topic and each set explains various techniques for loading, transforming,
extracting and reporting on data within a Hadoop cluster. You are encouraged to perform the tutorials in order
as the output of one is sometimes used as the input of another. However, if you would like to jump to a tutorial
in the middle of the flow, instructions for preparing input data are provided.

+ Loading Data into a Hadoop Cluster

+ Transforming Data within a Hadoop Cluster
+ Extracting Data from a Hadoop Cluster

+ Reporting on Data within a Hadoop Cluster
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Loading Data into a Hadoop Cluster

These scenario-based tutorials contain guidance and instructions on loading data into HDFS (Hadoop's
Distributed File System), Hive and HBase using Pentaho Data Integration (PDI)

+ Prerequisites

+ Using a Job Entry to Load Data into Hadoop's Distributed File System (HDFS)
+ Using a Job Entry to Load Data into Hive

+ Using a Transformation Step to Load Data into HBase
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Prerequisites

To perform the tutorials in this section you must have these components installed.

PDI—The primary development environment for the tutorials. See the Data Integration Installation Options if
you have not already installed PDI.

Apache Hadoop 0.20.X—A single-node local cluster is sufficient for these exercises, but a larger and/or remote
configuration also works. If you are using a different distribution of Hadoop see Configure Your Big Data
Environment. You need to know the addresses and ports for your Hadoop installation.

*Hive—A supported version of Hive. Hive is a Map/Reduce abstraction layer that provides SQL-like access to

Hadoop data. For instructions on installing or using Hive, see the Hive Getting Started Guide.

*HBase—A supported version of HBase. HBase is an open source, non-relational, distributed database that
runs on top of HDFS. For instructions on installing or using HBase, see the Getting Started section of the Apache
HBase Reference Guide.

*Component only required for corresponding tutorial.

+ Sample Data
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Sample Data

The tutorials in this section were created with this sample weblog data.

Tutorial

Using a Job Entry to Load Data
into Hadoop's Distributed File
System (HDFS)

Using a Job Entry to Load Data
into Hive

Using a Transformation Step to
Load Data into HBase

File Name

weblogs_rebuild.txt.zip

weblogs_parse.txt.zip

weblogs_hbase.txt.zip

https://help.pentaho.com/Documentation/5.4/0L0/040/020/040/000/000/000/000
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‘@ pentaho

Using a Job Entry to Load Data into Hadoop's
Distributed File System (HDFS)

In order to follow along with this tutorial, you will need

= Hadoop
= Pentaho Data Integration

You can use PDI jobs to put files into HDFS from many different sources. This tutorial describes how to create a

PDI job to move a sample file into HDFS.

If not already running, start Hadoop and PDI. Unzip the sample data files and put them in a convenient

location: weblogs_rebuild.txt.zip.

1. Create a new Job by selecting File > New > Job.

2. Add a Start job entry to the canvas. From the Design palette on the left, under the General folder, drag

a Start job entry onto the canvas.

rfl'u'iew _,_-;f Desfgn'-.__‘ |-—Elwe||:ume1 n,3J0h1 m'-.k.-
Steps | B (BE R G B F 0%
4 5 General

I START
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¥ Job START

% Set variables

& Success

¥ Transformation

3. Add a Hadoop Copy Files job entry to the canvas. From the Design palette, under the Big Data folder,

drag a Hadoop Copy Files job entry onto the canvas.

iy View [ * Design ™. [ Welcomel | w: Job 1 2
5 General
£ Mail
[0 File management e
5 Conditions * %
(7 Seripting START Hadoop Copy Fies
5 Bulk loading
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4. Connect the two job entries by hovering over the Start entry and selecting the output connector

, then drag the connector arrow to the Hadoop Copy Files entry.

ssdob1 B

= I'-*.-Jl B = ||100%

SR

START Hadoop Caopy Flies

5. Enter the source and destination information within the properties of the Hadoop Copy Files entry by
double-clicking it.

a. For File/Folder source(s), click Browse and navigate to the folder containing the downloaded
sample file weblogs rebuild.txt.

b. For File/Folder destination(s), enter hdfs://<NAMENODE>:<PORT>/user/pdi/
weblogs/raw, where NAMENODE and PORT reflect your Hadoop destination.

c. For Wildcard (RegExp), enter ~ . *\ . txt.

d. Click Add to include the entries to the list of files to copy.

e. Check the Create destination folder option to ensure that the weblogs folder is created in
HDFS the first time this job is executed.

When you are done your window should look like this (your file paths may be different).

@& Copy files... x
Job ertry narme: [Huduup Copy Files l
"General . Result files name
Settings
Include Subfolders [
Destination is a file O
empty folders @
Create destination folder |z
Replace existing files O
Remave source files
Copy previous results to args [
FilefFelder source | K3 |A_dd| |Bmwse...
FllefFalder destination l b | Browse...
Wildcard [RegExp) | 3
Files/Faolders: | nelete.
~ # FilefFolder source FilefFalder destinaticn Wildcard {RegExg
1 file:/{/sharefClowdera/Sample Data/weblogs_rebuild.txt , hdfs: f{localhast=9000/user fpdifweblogs/raw ot - | Edit
( . :
- oK || cancel

Click OK to close the window.
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6. Save the job by selecting Save as from the File menu. Enter load hdfs. kjb as the file name within
a folder of your choice.
7. Run the job by clicking the green Run button on the job toolbar

LY

s ¥ & &

, or by selecting Action > Run from the menu. The Execute a job window opens. Click Launch.

An Execution Results panel opens at the bottom of the Spoon interface and displays the progress of

the job as it runs. After a few seconds the job finishes successfully.

Execution results (=17

3 History [ & lnqqlng.'m' >

Jab ¢ Job Entry Comment Result Reason Filenamez N Lag date

= load_hdis
Job: load_hdfs start of job execution start 2012/01/27 D8:25:45
START start of [ob execution start 2012/01/27 08:25:45
START |ode execulion finished Success [i] 2012701027 08:25:45
Hadoop Copy Files Start of job execution Followed unconditional lirk: 2012/01§27 08:25:45
Hadaap Copy Files | execution finished SUCCEEE a 2012/01427 08:25:46
Jatx: load hifs |o® execution finished SUECess finished 1] 2012/01427 08:25:46

If any errors occurred the job entry that failed will be highlighted in red and you can use the Logging
tab to view error messages.

8. Verify the data was loaded by querying Hadoop.

a. From the command line, query Hadoop by entering this command.
hadoop fs -1s /user/pdi/weblogs/raw
This statement is returned

-rwxrwxrwx 3 demo demo 77908174 2011-12-28 07:16 /user/pdi/weblogs/raw/weblog raw.
txt
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Using a Job Entry to Load Data into Hive

In order to follow along with this tutorial, you will need
= Hadoop
= Pentaho Data Integration
= Hive
PDI jobs can be used to put files into Hive from many different sources. This tutorial instructs you how to use a

PDI job to load a sample data file into a Hive table.

Note: Hive could be defined with external data. Using the external option, you could define a Hive table that
uses the HDFS directory that contains the parsed file. For this tutorial, we chose not to use the external option
to demonstrate the ease with which files can be added to non-external Hive tables.

If not already running, start Hadoop, PDI, and the Hive server. Unzip the sample data files and put themin a
convenient location: weblogs_parse.txt.zip.

This file should be placed in the /user/pdi/weblogs/parse directory of HDFS using these three commands.

hadoop fs -mkdir /user/pdi/weblogs
hadoop fs -mkdir /user/pdi/weblogs/parse
hadoop fs -put weblogs parse.txt /user/pdi/weblogs/parse/part-00000

If you previously completed the Using Pentaho MapReduce to Parse Weblog Datatutorial, the necessary files
will already be in the proper directory.

1. Create a Hive Table.

a. Open the Hive shell by entering "'hive' atthe command line.

b. Create atable in Hive for the sample data by entering

create table weblogs (
client ip string,

full request date string,
day string,

month string,

month num int,

year string,
hour string,
minute string,
second string,
timezone string,
http verb string,
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uri string,

http status code string,

bytes returned
referrer

user agent

string,

string,

string)

row format delimited

fields terminated by '\t';

c. Close the Hive shell by entering 'quit'.

Create a new Job to load the sample data into a Hive table by selecting File > New > Job.
Add a Start job entry to the canvas. From the Design palette on the left, under the General folder, drag

a Start job entry onto the canvas.

[T View :? Design ™.

Steps [ =

4 [ General
= START
W DUMBY
@» Example plugin
% lob
B Setvariables
& Success

2% Transformation

4. Add a Hadoop Copy Files job entry to the canvas. From the Design palette, under the Big Data folder,

Bz Welcome! (R 90BT 0™
BEF G BB 100%

>

START

drag a Hadoop Copy Files job entry onto the canvas.

[Ty View | . Design .

Steps |'1:' =

5 General
£ Mail
[0 File management
5 Conditions
[Z0 Scripting
[ Bulk loading
=5 Big Data
&= Armazon EMR Job Executor
= Amazon Hive lob Executor
) Hadoop Copy Files
f-:“, Hadeop Job Executar
[F Oozielob Executor
[#¥% Pentaho MapReduce
f—i Pig Scnipt Executor
. Sgoop Export
& SgoopImport

5. Connect the two job entries by hovering over the Start entry and selecting the output connector

, then drag the connector arrow to the Hadoop Copy Files entry.

03 Welcomal | e j Job 1 :E

FE P L B = IDD;Q

S

START Hadoop Copy Fiks
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redobl

B i‘hﬂ. B = [100%

o3

START Hadoop Copy Flies

6. Enter the source and destination information within the properties of the Hadoop Copy Files entry by
double-clicking it.

a. For File/Folder source(s), enter hdfs://<NAMENODE>:<PORT>/user/pdi/
weblogs/parse, where NAMENODE and PORT reflect your Hadoop destination.

b. For File/Folder destination(s), enter hdfs://<NAMENODE>:<PORT>/user/hive/
warehouse/weblogs.

c. For Wildcard (RegExp), enter part-.*.
d. Click the Add button to add the entries to the list of files to copy.

When you are done your window should look like this (your file paths may be different)

o Copy files... x

Job entry name: |.... Copy File ‘

General . Result files name|

Settings
Include subfolders [
Destination is a file 7
i
Create destination folder |
Replace existing files [
Remove source files )
Copy previous results to args [

File/Folder swurcei ]‘3‘ @ Bmwse,..|
File/Folder destination | |¢’ Browse..|

Wildcard (RegExp) | |<t>
Files/Folders:
gelete|
~ # File/Folder source File/Folder destination Wildcard |
1 hdfs://localhost/user/pdifweblogs/parse : hdfs://localhost/userfhive/warehousejweblogs | part-* Edit |
] i I [*]
OK [ cancel

Click OK to close the window.

7. Save the job by selecting Save as from the File menu. Enter load hive.kjb as the file name within
a folder of your choice.

8. Run the job by clicking the green Run button on the job toolbar
n load_hive &I .

®r ¥ & &
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, or by selecting Action > Run from the menu. The Execute a job window opens. Click Launch.

An Execution Results panel opens at the bottom of the Spoon interface and displays the progress of
the job as it runs. After a few seconds the job finishes successfully.

Execution results =] el
(% History | {f Logging [Mﬁ' -
Job [ Job Entry Comment Result Reasan Filename
+ load_hive
Job: load_hive Start of job execution start
START Start of job execution start
START Job execution finished SuCCess
Copy Files Start of job execution Followed unconditional link
Copy Files Job execution finished SUCCEsS
Job: load_hive Job execution finished Success finished

If any errors occurred the job entry that failed will be highlighted in red and you can use the Logging
tab to view error messages.

9. Verify the data was loaded by querying Hive.
a. Open the Hive shell from the command line by entering hive.

b. Enter this query to very the data was loaded correctly into Hive.

select * from weblogs limit 10;

Ten rows of data are returned.
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Using a Transformation Step to Load Data into HBase

In order to follow along with this tutorial, you will need

= Hadoop
= Pentaho Data Integration
« HBase

This tutorial describes how to use data from a sample flat file to create a HBase table using a PDI

transformation. For the sake of brevity, you will use a prepared sample dataset and a simple transformation to

prepare and transform your data for HBase loads.

If not already running, start Hadoop, PDI, and HBase. Unzip the sample data files and put them in a convenient
location: weblogs_hbase.txt.zip

1. Create a HBase Table.
a. Open the HBase shell by entering hbase shell atthe command line.

b. Create the table in HBase by entering create 'weblogs', 'pageviews' inthe HBase
shell. This creates a table named weblogs with a single column family named pageviews.

c. Close the HBase shell by entering qui t.
From within the Spoon, create a new transformation by selecting File > New > Transformation.

Identify the source where the transformation will get data from. For this tutorial your source is a text
file (.txt). From the Input folder of the Design palette on the left, add a Text File Input step to the

transformation by dragging it onto the canvas.

iy View (7 Design™._ | @ welcome! [
Steps : Eel B =]
[+ £5 Cassandra
[+ =3 Hadoop
| =
- @ doput =N
B Csv file input Text file input
7 Data Grid

4. Edit the properties of the Text file input step by double-clicking the icon. The Text file input dialog box
appears.

5. From the File tab, in the File or Directory field, click Browse and navigate to the weblog hbase.txt
file. Click Add.

The file appears in the Selected files pane.
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Stepname [texe file input

TFile _Content| Error Handling| Filbers | Fields  Additional output felds
File or directory | |® acd| Browse...

Regular Expression | |

Exclude Begular I:xnrcssiun[ |®

Selected files: o | File/Directory wildcard (RegExp) |
1 fshareyM apRHowTos MapR How Tos/guides/MapRDale/weidogs_hbase.lxl | el .
! ele

Edit =
&l . | 1]
Accept filenames from previous steps
Accept filenames from previous step O
QK | [ Ereviev rows ] | Cancel |

Configure the contents of the file by switching to the Content tab.
a. For Separator, clear the contents and click Insert TAB.
b. Check the Header checkbox.
c. For Format, Select Unix from the drop-down menu.

Text file input

Step name [Text file input

Filz|Content ™. Error Handling Filters | Fields | Additional output fields

Filelype |coy -1
Separator % | Insert TAE
Enclosure |- 1

H

Escape

Header  Mumber of header lines [

Footar |
wrapped lincs? |
Paged leyoul (printout)? |

COmpression |yana -

Mo empty rows @
Include filename in output? [~ F

| oK Previewrows || cancel

Configure the input fields.
a. From the Fields tab, select Get Fields to populate the list the available fields.
b. Adialog box appears asking for Number of sample lines. Enter 100 and click OK.
¢. Change the Type of the field named key to String and set the Length to 20.
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F Text file input »
Step name [Text file input ]
File |Content Error Handling Filters (Fields™_additional output fields
~ #|Name  Type Format  Paosition Length  Preg
1 key String #. 4 20
2ijan | Integer L # i 15 |
3 feb { Integer  # ’ i15 i
4! mar ! Integer L # i 15 i
5] apr | Integer | # 15
6imay | Integer  # 15
7ijun Integer # ‘15
81 jul ! Integer  # 15
9 aug | Integer P # i15 i
10isep | lInteger ! 15 E
11} oct  Integer P # 15 i
12 nov i Integer L # {15
13idec  |Integer L # 15
[ T —— B
[get Fields ]
QK [ Breview rows || Cancel

Click OK to close the window.

8. On the Design palette, under Big Data, drag the HBase Output to the canvas. Create a hop to connect
your input and HBase Output step by hovering over the input step and clicking the output connector

, then drag the connector arrow to the HBase Output step.

¥ Transformation 1 =@

BPiliEnsF ot

E -

Taxt file input HBase Output

9. Edit the HBase Output step by double-clicking it. You must now enter your Zookeeper host(s) and port
number.

a. Forthe Zookeeper hosts(s) field, enter a comma separated list of your HBase Zookeeper Hosts.
For local single node clustersuse 1ocalhost.

b. For Zookeeper port, enter the port for your Zookeeper hosts. By default thisis 2181.

10. Create a HBase mapping to tell Pentaho how to store the data in HBase by switching to the Create/Edit
mappings tab and changing these options.

https://help.pentaho.com/Documentation/5.4/0L0/040/020/040/000/000/030 33/60
Updated: Wed, 27 May 2015 15:24:05 GMT



a. For HBase table name, select weblogs.
b. For Mapping name, enter pageviews.
c. Click Get incoming fields.

d. For the alias key change the Key column to Y, clear the Column family and Column name
fields, and set the Type field to String. Click Save mapping.

i HBase output x
Step Name | HBase Output |
Configure connection _”Create,fEdi't mappings
HBase table name |weblng5 |T|
Mapping name|mge,l,iew5 v
~ # Alias Key Column family Column name Type | Indexed va o
1: key T i ' String |
21 apr N: pageviews: apr Long
3! aug N: pageviews: aug L Long |
4 dec M pageviewsg dec Long
5i feb Ni pageviews : feb Long 3
6! jan M pageuiewsé jan Long
7ijul N pageviews : jul Lﬂngg
8! jun N pageviews | jun Long |
9} mar N: pageviews : mar Long !
10} may N: pageviews : may Long |
11} nov N pageviews | nov Lungé =
] : : [ : : : I [*] -
Save mapping | | Delete mapping Get incoming fields
oK Cancel

11. Configure the HBase out to use the mapping you just created.
a. Go back to the Configure connection tab and click Get table names.

b. For HBase table name, enter weblogs.

c. Click Get mappings for the specified table.
d. For Mapping name, select pageviews. Click OK to close the window.

Save the transformation by selecting Save as from the File menu. Enter load_hbase.ktr as the file name
within a folder of your choice.

12. Run the transformation by clicking the green Run button on the transformation toolbar

+n Ipad_hbase =2 -

@il %P el
, or by choosing Action > Run from the menu. The Execute a transformation window opens. Click
Launch.

An Execution Results panel opens at the bottom of the Spoon interface and displays the progress of

the transformation as it runs. After a few seconds the transformation finishes successfully.
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Execution Results
(% Execution History | i Logging [## Step Metrics

£

~ # Stepname Copynr Read Written

.7 Performance Graph|

1! Text file input
2| HBase Output

0{ 27300{ 27300

0! o) 27300; 27301!

If any errors occurred the transformation step that failed will be highlighted in red and you can use the

Logging tab to view error messages.

13. Verify the data was loaded by querying HBase.
a.

hbase shell
b. Query HBase by entering this command.
scan 'weblogs', {LIMIT => 10}

Ten rows of data are returned.
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Transforming Data within a Hadoop Cluster

These tutorials contain guidance and instructions on transforming data within the Hadoop cluster using
Pentaho MapReduce, Hive, and Pig.

* Using Pentaho MapReduce to Parse Weblog Data—How to use Pentaho MapReduce to convert raw

weblog data into parsed, delimited records.

* Using Pentaho MapReduce to Generate an Aggregate Dataset—How to use Pentaho MapReduce to
transform and summarize detailed data into an aggregate dataset.

* Transforming Data within Hive—How to read data from a Hive table, transform it, and write it to a Hive
table within the workflow of a PDI job.

* Transforming Data with Pig—How to invoke a Pig script from a PDI job.
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Extracting Data from a Hadoop Cluster

These tutorials contain guidance and instructions on extracting data from Hadoop using HDFS, Hive, and
HBase.

* Extracting Data from HDFS to Load an RDBMS—How to use a PDI transformation to extract data from
HDFS and load it into a RDBMS table.

* Extracting Data from Hive to Load an RDBMS—How to use a PDI transformation to extract data from Hive
and load it into a RDBMS table.

* Extracting Data from HBase to Load an RDBMS—How to use a PDI transformation to extract data from
HBase and load it into a RDBMS table.

* Extracting Data from Snappy Compressed Files—How to configure client-side PDI so that files
compressed using the Snappy codec can be decompressed using the Hadoop file input or Text file input

step.
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Reporting on Data within a Hadoop Cluster

These tutorials contain guidance and instructions about reporting on data within a Hadoop cluster.

* Reporting on HDFS File Data—How to create a report that sources data from a HDFS file.
* Reporting on HBase Data—How to create a report that sources data from HBase.

* Reporting on Hive Data—How to create a report that sources data from Hive.
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MapR Tutorials

These tutorials are organized by topic and each set explains various techniques for loading, transforming,
extracting and reporting on data within a MapR cluster. You are encouraged to perform the tutorials in order
as the output of one is sometimes used as the input of another. However, if you would like to jump to a tutorial
in the middle of the flow, instructions for preparing input data are provided.

+ Loading Data into a MapR Cluster

+ Transforming Data within a MapR Cluster
+ Extracting Data from a MapR Cluster

+ Reporting on Data within a MapR Cluster
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Loading Data into a MapR Cluster

These tutorials contain guidance and instructions on loading data into CLDB (MapR'’s distributed file system),
Hive, and HBase.

* Loading Data into CLDB—How to use a PDI job to move a file into CLDB.

* Loading Data into MapR Hive—How to use a PDI job to load a data file into a Hive table.

* Loading Data into MapR HBase—How to use a PDI transformation that sources data from a flat file and

writes to an HBase table.

https://help.pentaho.com/Documentation/5.4/0L0/040/020/040/010/000 40/60
Updated: Wed, 27 May 2015 15:24:05 GMT


http://wiki.pentaho.com/display/BAD/Loading+Data+into+the+MapR+filesystem
http://wiki.pentaho.com/display/BAD/Loading+Data+into+MapR+Hive
http://wiki.pentaho.com/display/BAD/Loading+Data+into+MapR+HBase

‘@ pentaho

Transforming Data within a MapR Cluster

These tutorials contain guidance and instructions on leveraging the massively parallel, fault tolerant MapR
processing engine to transform resident cluster data.

* Using Pentaho MapReduce to Parse Weblog Data in MapR—How to use Pentaho MapReduce to convert
raw weblog data into parsed, delimited records.

* Using Pentaho MapReduce to Generate an Aggregate Dataset in MapR—How to use Pentaho MapReduce
to transform and summarize detailed data into an aggregate dataset.

* Transforming Data within Hive in MapR—How to read data from a Hive table, transform it, and write it to

a Hive table within the workflow of a PDI job.

* Transforming Data with Pig in MapR—How to invoke a Pig script from a PDI job.
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Extracting Data from a MapR Cluster

These tutorials contain guidance and instructions on extracting data from a MapR cluster and loading it into an
RDBMS table.

* Extracting Data from CLDB to Load an RDBMS—How to use a PDI transformation to extract data from
MapR CLDB and load it into a RDBMS table.

* Extracting Data from Hive to Load an RDBMS in MapR—How to use a PDI transformation to extract data
from Hive and load it into a RDBMS table.

* Extracting Data from HBase to Load an RDBMS in MapR—How to use a PDI transformation to extract
data from HBase and load it into a RDBMS table.
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Reporting on Data within a MapR Cluster

These tutorials contain guidance and instructions about reporting on data within a MapR cluster.

* Reporting on CLDB File Data —How to create a report that sources data from a MapR CLDB file.

* Reporting on HBase Data in MapR—How to create a report that sources data from HBase.

* Reporting on Hive Data in MapR—How to create a report that sources data from Hive.
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Cassandra Tutorials

These tutorials demonstrate the integration between Pentaho and the Cassandra NoSQL Database, specifically

techniques about writing data to and reading data from Cassandra using graphical tools. These tutorials also

include instructions on how to sort and group data, create reports, and combine data from Cassandra with
data from other sources.

* Write Data To Cassandra—How to read data from a data source (flat file) and write it to a column family
in Cassandra using a graphic tool.

* How To Read Data From Cassandra—How to read data from a column family in Cassandra using a
graphic tool.

* How To Create a Report with Cassandra—How to create a report that uses data from a column family in
Cassandra using graphic tools.
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MongoDB Tutorials

These tutorials demonstrate the integration between Pentaho and the MongoDB NoSQL Database, specifically
how to write data to, read data from, MongoDB using graphical tools. These tutorials also include instructions
on sorting and grouping data, creating reports, and combining data from Mongo with data from other sources.

* Write Data To MongoDB—How to read data from a data source (flat file) and write it to a collection in
MongoDB

* Read Data From MongoDB—How to read data from a collection in MongoDB.
* Create a Report with MongoDB—How to create a report that uses data from a collection in MongoDB.

* Create a Parameterized Report with MongoDB—How to create a parameterize report that uses data from
a collection in MongoDB.

https://help.pentaho.com/Documentation/5.4/0L0/040/020/040/030
Updated: Wed, 27 May 2015 15:24:05 GMT

45/60


http://wiki.pentaho.com/display/BAD/Write+Data+To+MongoDB
http://wiki.pentaho.com/display/BAD/Read+Data+From+MongoDB
http://wiki.pentaho.com/display/BAD/Create+a+Report+with+MongoDB
http://wiki.pentaho.com/display/BAD/Create+a+Parameterized+Report+with+MongoDB

@ pentaho

Managing Reusable Hadoop Cluster Configuration
Settings

When you configure a job or transformation to use a Hadoop cluster, you can store some of
the cluster configuration settings, like hostnames and port numbers, so they can be reused. This saves you

time because you do not have to enter the same configuration information again.

NOTE:
This feature is not available for all steps and entries. Check the step and entry documentation to see

whether a specific step or entry supports reusable Hadoop Cluster configurations.

Specify New Hadoop Cluster Configurations

You can easily specify new Hadoop cluster configuration that can be reused in other places. The cluster
configuration information is available for other users if you are connected to a repository when it is created. If
you are not connected to the repository when you create the Hadoop Cluster configuration, then the
configuration is available for use in your other steps and entries that support this feature. You can specify new

Hadoop cluster configurations in three places:

* Individual transformation steps and job enties such as the Pentaho MapReduce job entry
+ Transformation or job View tab,
* Repository Explorer window.

Specify Hadoop Cluster Configurations in a Step or Entry

To specify Hadoop cluster configurations in a step or entry, do the following.

1. In Spoon, create a new job or transformation or open an existing one.
2. Drag a step or entry that supports named Hadoop cluster configurations to the Spoon canvas.

3. Click the New button that is next to the Hadoop Cluster field. Since the Hadoop Cluster field location
varies, see the step or entry documentation for the location of the field. The following screenshot shows
the Hadoop Cluster field in the Oozie Job Executor entry.

r
@ Cozie Job Executor n iEI

Marme: | [Jozic Job Executor
Hadeop Cluster: Edit || Mewr
Enable Blocking: il
Polling Interval (mz): 200 L 2
Woarkflow Properties: & Browse
|
Advanced Options Cancel
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1. The Hadoop cluster window appears. Enter a name for the configuration.
2. Indicate whether you are using a MapR cluster. If you are, click the Use MapR Client checkbox.

Hadoop cluster

Cluster Mame:

| mMyCluster

|| Use MapR client

HDFS

Hostname:

[localhost

Pork:
le |s020

Username:

Password:

|user

JobTracker

Hostname:

Port:

|localhost

Zookeeper

Hostname:

| [s03z

Port:

|lecalhost

le [2181

Oozie
URL:
|http:/flocalhost:8080/00zie e

@ Help [ ok cancel

1. Enter the rest of the information for the cluster configuration.
2. When complete, click the OK button. The new configuration appears in the drop down list.

3. The Hadoop cluster window appears. Enter a name for the configuration, then enter the rest of the
information for the cluster configuration.

4, When complete, click the OK button. The new configuration appears in the drop down list.

Specify Hadoop Cluster Configurations in the View Tab

To specify Hadoop cluster configurations in the transformation or job View tab, complete these steps.

1. In Spoon, create a new job or transformation or open an existing one.
2. Click the View tab.

o] view - B Design|
Explorer |Q @ % 3=
¥ e Job

v [ Database connections
[ Job entries
* [ Hadgop dlusters
[ apahad
e
3 slave server

1. Right-click the Hadoop cluster folder, then click New. The Hadoop cluster window appears.

2. Enter a name for the configuration, then enter the rest of the information for the cluster.
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3. When complete, click the OK button. The new Hadoop cluster configuration appears under the Hadoop
clusters folder.

Specify Hadoop Cluster Configurations in the Repository Explorer

To specify Hadoop cluster configurations in the Repository Explorer window, do the following.

In Spoon, connect to the repository where you want to store the transformation or job.
Select Tools > Repository > Explore to open the Repository Explorer window.

Click the Hadoop clusters tab.

Click the New button. The Hadoop Cluster window appears.

Enter a name for the configuration, then enter the rest of configuration information.

AN A S o

When complete, click the OK button. The new Hadoop cluster appears in the list.

Edit Hadoop Cluster Configurations

You can edit Hadoop cluster configurations in three places:

* Individual transformation steps and job enties such as the Pentaho MapReduce job entry
 Transformation or job View tab
* Repository Explorer window

How updates occur depend on whether you are connected to the repository.

* If you are connected to a repository, Hadoop Cluster configuration changes are picked up by all
transformations and jobs in the repository. The Hadoop Cluster configuration is loaded during execution
unless it cannot be found. If the configuration cannot be found, the configuration values that were stored
when the transformation or job was saved are used instead.

* If you are not connected to a repository, the Hadoop Cluster configuration changes are only picked up by
your local (file system) transformations and jobs. If you run these transformations and jobs outside of
Kettle, they will not have access to the Hadoop Cluster configuration, so a copy of the configuration is
saved as a fallback. Note that changes to the Hadoop Cluster configuration are not updated in any
transformations or jobs for the purpose of fallback unless they are re-saved.

NOTE:

We recommend that you use Kettle variables for each value in the Hadoop Cluster configuration to mitigate

some of the risk associated with running jobs and transformations in environments that are disconnected

from the repository.

Edit Hadoop Cluster Configuration in a Step or Entry

To edit Hadoop cluster configurations in a step or entry, complete these steps.

1. In Spoon, open the step or entry that has the Hadoop cluster configuration you want to edit.

2. In the Hadoop Cluster field, select the configuration from the drop down menu, then click the Edit
button. Since the Hadoop Cluster field location varies, see the step or entry documentation for the
location of the field.

3. The Hadoop cluster window appears. Make changes as needed.
4. When finished, click the OK button.
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Edit Hadoop Cluster Configurations in the View Tab
To edit Hadoop cluster configurations from the transformation or job View tab, complete these steps.
1. Open the transformation or job in Spoon.

2. Click the View tab.
3. Click the Hadoop Clusters folder to open it.

4. Right-click the configuration you want to edit, then select Edit. The Hadoop cluster window appears.

Make changes as needed.
5. When finished, click the OK button.

Edit Hadoop Cluster Configurations in the Repository Explorer

To edit Hadoop cluster configurations from the Repository Explorer window, do the following.

In Spoon, connect to the repository where you stored the transformation or job.
Select Tools > Repository > Explore to open the Repository Explorer window.
Click the Hadoop Clusters tab.

Select the configuration you want to edit, then click the Edit button.

The Hadoop cluster window appears. Make changes as needed.

When finished, click the OK button.

o v A wnN =

Duplicate a Hadoop Cluster Configuration

To duplicate or clone a Hadoop Cluster configuration, do the following.

1. Open a transformation or job in Spoon.

2. Click the View tab.

3. Click the Hadoop clusters folder to see its contents.

4. Right-click the Hadoop cluster you want to duplicate and select Duplicate.

5. The Hadoop cluster window appears. Enter a different name in the Cluster Name field.
6. Click OK.

Delete Hadoop Cluster Configuration
You can delete Hadoop cluster configurations as needed. Once you delete a configuration, it cannot be

restored, but you can always specify a new Hadoop cluster configuration again.

Note that you can still run transformations and jobs that reference deleted named Hadoop cluster

configurations because configuration details are stored in the transformation and job metadata files.

Delete Hadoop Cluster Configurations in the View Tab
To delete Hadoop cluster configuration in a transformation or job, complete these steps.
1. Open a transformation or job in Spoon.

2. Click the View tab.
3. Click the Hadoop clusters folder to see its contents.
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4, Right-click the Hadoop cluster you want to delete and select Delete.
5. A message appears asking if you really want to delete the configuration. Click Yes.

Delete Hadoop Cluster Configuration in the Repository Explorer

To delete Hadoop cluster configurations from the Repository Explorer window, do the following.

1. In Spoon, connect to a repository, then select Tools > Repository > Explore.
2. Click the Hadoop Clusters tab.
3. Click the Hadoop cluster configuration you want to delete and click the Delete button.

4. A message appears asking if you really want to delete the Hadoop cluster configuration. Click Yes.
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Using the YARN Workspace Folder to Copy Files to the
YARN Cluster

If you start a job that will run on a YARN cluster, but it needs other files to execute - such as variables from your
local copy of kettle.properties - those files will need to be copied to the YARN cluster. An easy way to do
this is to add those files to the YARN Workspace folder. At runtime PDI copies all of the files in the YARN
Workspace folder to the YARN cluster. This feature is well-suited for jobs that move through the development,
testing, and staging lifecycle because the job uses the appropriate configuration files in the KETTLE HOME

directory for the environment in which it runs.

CAUTION:

Files in the YARN Workspace folder are copied to the YARN cluster every time you run a job that starts

the YARN Kettle Cluster. If you don't want to overwrite files that have the same names that are already on
the YARN Kettle Cluster, delete files from the YARN Workspace folder. Then, in the Start a YARN Kettle
Cluster step window, deselect the appropriate checkboxes in the Copy Local Resource Files to YARN section

of the window.

Add Files to the YARN Workspace Folder

These instructions explain how to configure the Start a YARN Kettle Cluster entry so that following files are
copied at runtime, to the YARN Workspace folder and then to the YARN

cluster: kettle.properties, shared.xml, and repositories.xml. These instructions also explain

how to manually copy additional files to the folder.

If the job is run from your local installation, the configuration files from your KETTLE HOME directory are
copied to the YARN Workspace folder. If the job is scheduled or is run on a Pentaho DI Server, the

configuration files from the server's configured KETTLE HOME are copied to the YARN Workspace folder.

Complete these steps.

1. Set the active YARN Hadoop cluster using the instructions found in Configuring Pentaho for Your
Hadoop Distro and Version.

2. Complete the instructions in the Additional Configuration for YARN shims article.
3. In Spoon, create or open a job that contains the Start a YARN Kettle Cluster entry.
4. Open the Start a YARN Kettle Cluster entry.

5. Select any combination of the kettle.properties, shared.xml, and repository.xml checkboxes in the
Copy Local Resource Files to YARN section of the window.

6. Save and close the Start a YARN Kettle Cluster entry.

7. If you want to copy other files to the cluster, manually copy them to the YARN Workspace folder
here: pentaho-big-data-plugin/plugins/pentaho-kettle-yarn-plugin/workspace.
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8. Save and run the job.

At runtime, the kettle.properties, shared.xml, and repositories.xml files (whatever was selected) are
copied to the YARN Workspace folder and then to the YARN cluster.

Delete Files from the YARN Workspace Folder
To delete files from the YARN Workspace folder manually remove them. The YARN Workspace Folder is kept

here: pentaho-big-data-plugin/plugins/pentaho-kettle-yarn-plugin/workspace.
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Using Spark with PDI

These instruction explain how to use the Spark Submit job entry to run the Word Count sample on a text file

that you supply.

Install the Spark Client

Before you start, you must install and configure the Spark client according to the instructions in the Spark

Submit job entry, which can be found here: http://wiki.pentaho.com/display/EAl/Spark+Submit.

Modify the Spark Sample

The following example demonstrates how to use PDI to submit a Spark job.

Open and Rename the Job
NOTE:
To copy files in these instructions, use either the Hadoop Copy Files job step or Hadoop command line tools.
For an example of how to do this using PDI, check out our tutorial at http://wiki.pentaho.com/display/BAD/
Loading+Data+into+HDES.

1. Copy a text file that contains words that you'd like to count to the HDFS on your CDH 5.3 cluster.

2. Start Spoon.

3. Open the Spark Submit.kjb job, whichisin <pentaho-home>/design-tools/data-
integration/samples/jobs.

4. Select File > Save As, then save the file as Spark Submit Sample.kijb.
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Submit the Spark Job

To submit the spark job, complete the following steps.

1. Open the Spark Pl job entry. Spark Pl is the name given to the Spark Submit entry in the sample.
2. In the Job Setup tab, indicate the path to the spark-submit utility in the Spark Submit Utility field. Itis

located in where you installed the Spark client.

3. Indicate the path to your spark examples jar (either the local version or the one on the cluster in the

HDFS) in the Application Jar field. The Word Count example is in this jar.

4. In the Class Name field, add the following: org.apache. spark.examples.JavaWordCount.

5. We recommend that you set the Master URL to yarn-client. To read more about other execution

modes, see https://spark.apache.org/docs/1.2.1/submitting-applications.html.
6. In the Arguments field, indicate the path to the file you want to run Word Count on.

7. Click the OK button.
8. Save the job.

9. Run the job. As the program runs, you will see the results of the word count program in the Execution

pane.
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PDI Hadoop Configurations

Within PDI, a Hadoop configuration is the collection of Hadoop libraries required to communicate with a

specific version of Hadoop and related tools, such as Hive HBase, Sqoop, or Pig.

Hadoop configurations are defined in the plugin.properties file and are designed to be easily configured

within PDI by changing the active.hadoop.configuration property. The plugin.properties file resides

in the pentaho-big-data-plugin/ folder.

All Hadoop configurations share a basic structure. Elements of the structure are defined in the table following

this code block.

configuration/
|-- 1lib/

client/
pmr/
|-- '-- *.jar

| -— config.properties
|-- core-site.xml

"—- configuration-implementation.jar

Configuration Element

lib/

client/

pmr/

*.jar

config.properties
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Libraries specific to the version of Hadoop this
configuration was created to communicate with.

Libraries that are only required on a Hadoop client,
for instance hadoop-core-* or hadoop-client-*

Jar files that contain libraries required for parsing
data in input/output formats or otherwise outside of
any PDI-based execution.

All other libraries required for Hadoop configuration
that are not client-only or special pmr jar files that
need to be available to the entire JVM of Hadoop job
tasks.

Contains metadata and configuration options for
this Hadoop configuration. Provides a way to define
a configuration name, additional classpath, and
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core-site.xml

configuration-implementation.jar

+ Create a New Hadoop Configuration

native libraries the configuration requires. See the
comments in this file for more details.

Configuration file that can be replaced to set a site-
specific configuration, for example hdfs-site.xml
would be used to configure HDFS.

File that must be replaced in order to communicate
with this configuration.

+ Include or Exclude Classes or Packages for a Hadoop Configuration

https://help.pentaho.com/Documentation/5.4/0L0/040/030
Updated: Wed, 27 May 2015 15:24:05 GMT

56/60



@ pentaho

Create a New Hadoop Configuration

If you have a Hadoop distribution not supported by Pentaho, or you have modified your Hadoop Installation in

such a way that it is no longer compatible with Pentaho, you may need to create a new Hadoop configuration.

Changing which version of Hadoop PDI can communicate with requires you to swap the appropriate jar files

within the plugin directory and then update the plugin.properties file.

CAUTION:

Creating a new Hadoop configuration is not officially supported by Pentaho. Please inform Pentaho support
regarding your requirements.

1. Ildentify which Hadoop configuration most closely matches the version of Hadoop you want to
communicate with. If you compare the default configurations included the differences are apparent.
Copy this folder, then paste and rename it. The name of this folder will be the name of your new
configuration.

2. Copy the jar files for your specified Hadoop version.
3. Paste the jar files into the 1ib/ directory.

4. Changethe active.hadoop.configuration= propertyinthe plugins/pentaho-big-
dataplugin/plugin.properties file to match your specific Hadoop configuration. This property
configures which distribution of Hadoop to use when communicating with a Hadoop cluster and must
match the name of the folder you created in Step 1. Update this property if you are using a version
other than the default Hadoop version.

https://help.pentaho.com/Documentation/5.4/0L0/040/030/000 57/60
Updated: Wed, 27 May 2015 15:24:05 GMT



@ pentaho

Include or Exclude Classes or Packages for a Hadoop
Configuration

You have the option to include or exclude classes or packages from loading with a Hadoop configuration.
Configure these options within the plugin.properties file located at plugins/pentaho-big-data-

plugin. For additional information, see the comments within the plugin.properties file.

Including Additional Class Paths or Libraries

To to include additional class paths, native libraries, or a user-friendly configuration name, include the

directory within classpath property within the big data plugin.properties file.

Exclude Classes or Packages

To exclude classes or packages from being loaded twice by a Hadoop configuration class loader, include them
inthe ignored.classes property within the plugin.properties file. This is necessary when logging

libraries expect a single class shared by all class loaders, as with Apache Commons Logging for example.
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PDI Big Data Transformation Steps

This section contains reference documentation for transformation steps which enable PDI to work with big
data technologies.

Please see Create DI Solutions for additional transformation step references.

* Avro Input

* Cassandra Input

* Cassandra Output
* CouchDB

* Hadoop File Input

* Hadoop File Output
* HBase Input

* HBase Output

* HBase Row Decoder
* MapReduce Input

* MapReduce Output
* MongoDB Input

* MongoDB Output

* Splunk Input

* Splunk Output

* SSTable Output
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PDI Big Data Job Entries

This section contains reference documentation for job entries which enable PDI to work with big data
technologies.

Please see Using Pentaho Data Integration for additional transformation step and job entry references.

* Amazon EMR Job Executor
* Amazon Hive Job Executor
* Hadoop Copy Files

* Hadoop Job Executor

* Qozie Job Executor

* Pentaho MapReduce

* Pig Script Executor

* Sqoop Export

* Sgoop Import

* Start a YARN Kettle Cluster

* Stop a YARN Kettle Cluster
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